GitHub | Documentation | Become a Patron

Starting Node Server??



  • I know javascript but new to node I ran the examples with no problem I ran it just like it said:
    npm install
    npm run bundle-colyseus-client
    npm start

    But when i tried to run my own project i get this error:

    c:\Projects\play>npm start
    npm ERR! path c:\Projects\play\package.json
    npm ERR! code ENOENT
    npm ERR! errno -4058
    npm ERR! syscall open
    npm ERR! enoent ENOENT: no such file or directory, open 'c:\Projects\play\package.json'
    npm ERR! enoent This is related to npm not being able to find a file.
    npm ERR! enoent

    npm ERR! A complete log of this run can be found in:
    npm ERR! C:\Users\owner\AppData\Roaming\npm-cache_logs\2018-05-13T20_46_48_575Z-debug.log

    I only have 1 javascript file with the node modules. Thanks in advance for help!


  • administrators

    Hey @btgames, I'd suggest not using uws on your local environment. You can remove uws from your package.json.

    I'm not a Windows user, but for some reason uws can't be compiled on it. Maybe you'd need some extra dependencies installed in your system to enable its compilation.

    Cheers!



  • thanks...I did that now i get this error:

    index@1.0.0 start c:\Projects\play
    cross-env DEBUG=* ./node_modules/.bin/supervisor -i node_modules -- index.js

    'cross-env' is not recognized as an internal or external command,
    operable program or batch file.
    npm ERR! code ELIFECYCLE
    npm ERR! errno 1
    npm ERR! index@1.0.0 start: cross-env DEBUG=* ./node_modules/.bin/supervisor -i node_modules -- index.js
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the index@1.0.0 start script.
    npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:
    npm ERR! C:\Users\owner\AppData\Roaming\npm-cache_logs\2018-05-13T21_05_40_940Z-debug.log

    I have it narrowed down thou its something in my package.json file
    Appreciate the help!!